Warning: file_exists(): open_basedir restriction in effect. File(/lib/tpl/vector/user/print.css) is not within the allowed path(s): (/www/wwwroot/wiki.ijguo.cn/:/tmp/) in /www/wwwroot/wiki.ijguo.cn/lib/tpl/vector/main.php on line 467

这是一个关于低压电器知识百科的网站!


前言

ANSYS Electromagnetics Suite电磁场仿真可帮助用户快速、经济地设计出创新性的电子电气产品。Ansys 软件能够对组件、电路和系统设计的电磁性能进行独立仿真,还可以对温度、振动和其他重要机械效应进行评估。

对于想要从事有关行业的人来说,学会ANSYS Electromagnetics Suite是必不可少的。软件的GUI对应的名称是ANSYS Electronics,我们常说的HFSS从2016的版本开始,已经是ANSYS Electronics中的一个组件。

同时,本文为作者的学习笔记,是HFSS(ANSYS Electronics)系列的第一篇文章,也是入门系列的文章,采用的软件版本是ANSYS Electromagnetics Suite 2021 R2。

软件安装

推荐一位大佬的博客,ADS、HFSS、AD这些电子行业常用的软件,在他的博客都能下载到:ANSYS Electromagnetics Suite 2021 R2 电磁场仿真软件下载及安装教程

 软件安装完成后的桌面图标

安装好了后,点击上面这个图标能打开软件。

建立工程

 默认工程与新建 HFSS 设计入口

新打开的软件,默认已经建立好了一个项目工程,如橙色部分。按照红色部分的指引,新建一个HFSS的设计。

从中可以看出,它支持建立一个3D的设计。这里我们直接选择第一个,建立一个普通的设计。

 选择设计类型

建立完设计后,就变成下面的界面。

 建立设计后的软件界面

绘图工具

这里重点说一下Draw区的一些工具。

 Draw 区绘图工具总览

先看看左边部分,这部分主要关于界面操作。从左到右依次是:

  1. 对图形操作,包括保存,复制,粘贴,剪切,删除等。
  2. 选择图形时可以选择的类型,包括Object,Group,Submodel等。
  3. 选择查看或隐藏某些图形。
  4. 对编辑界面的调整,包括界面大小,方位,旋转,视图(例如左视图)。
  5. 将某些图形充满整个窗口,Fit All代表所有,Fit Selected代表选中的。

 左侧工具(界面操作)

再来看看中间部分,这里主要关于绘图。从左到右依次是:

  1. 创建简单的3D图形,包括长方体,圆台或圆锥,立体螺旋结构,圆柱,球体,平面螺旋结构,正多边形台体,圆环,梯形线。
  2. 创建简单的2D图形,包括矩形,圆等。
  3. 创建简单的线条,包含直线,圆弧,自定义曲线等。
  4. 创建区域,添加点,添加切面。
  5. 操作图形,包括移动,旋转,镜像。
  6. 操作图形同时复制一份,包括移动,旋转,镜像。
  7. 布尔运算,包括并,交,减等。
  8. 将平面变成立体。
  9. 对角进行裁剪,变成弧边或斜边。
  10. 对面,网格,边进行操作。

 中间工具(绘图)

最后看看右边部分,这里主要关于网格和坐标。从左到右依次是:

  1. 对坐标的操作。
  2. 测量图形和修改单位(公制和英制,也就是mm和mil)。
  3. 显示网格,默认是XY网格。
  4. 吸附特殊点,例如网格交点,图形中心,图形边角,图形边线中心等。
  5. 层叠有关的设置。

 右侧工具(网格和坐标)

具体的,这些工具如何使用?其实是非常简单的,这里就不一一细说了,自己把每个工具都试一下,就能明白其中的奥秘,尤其是学习过AutoCAD的人,那是很快上手的。

修改属性

当绘制了一个图形时,如何修改它的属性?

物理化学属性

在做仿真之前,是需要对图形的物理化学属性进行定义的,例如介电常数,电阻率等。单击图形,使其变成粉红色,会出现左边的Properties窗口。常用的有四个,依次为:

  1. 图形的名字。
  2. 图形的材料属性,例如介电常数,电阻率。
  3. 图形的显示颜色。
  4. 图形的显示透明度。

 Properties 属性窗口

其中最重点的是第二项Material。点开选项,点击Edit。

 Material 材料编辑入口

可以看出,ANSYS给出了很多常用的材料,例如常见的空气air,还有一些常见的金属例如氧化铝、铜,以及一些厂家的高频板材基板。

 材料列表

在搜索框里搜索,可以查找对应的材料,例如搜索铜。

 搜索材料(铜)

在下面的选项中,可以对材料进行修改,例如修改,添加,删除等操作。

 材料编辑选项

尺寸坐标属性

在绘制了图形后,我们怎样修改尺寸和坐标属性。一般都是选择Model下的黄色图标的图形,例如CreateBox和CreatePolyline,双击它。

 工程树中的 CreateBox / CreatePolyline

对于这个长方体,可以修改坐标值。

 修改长方体坐标

对于线段,可以修改类型,宽度,高度等。

 修改线段类型、宽度、高度

设置变量

当我们需要对电路进行仿真优化的时候,就需要对我们所关心的参数进行扫描。在扫描之前,需要把参数变成一个变量。

普通变量

如果仅有一个设计,或者设计之间的数据不需要互通,那么设置一个普通变量即可。双击要添加变量的图形,例如这里选择一个线段(已经转变成了微带线)。直接把数值变成变量名即可。

 属性中直接填变量名

如果一开始的值是0或未知,则会弹出一个窗口,让你设置一个初值。

 设置变量初值

设置好的变量也可以进行修改。在HFSS菜单中找到倒数第二项。

 HFSS 菜单中的变量入口

即可对变量进行修改。

 修改变量

全局变量

如果我们有多个设计,想在多个设计中使用同一个变量,那么就需要使用全局变量。

 Project 菜单

选择Project菜单中的倒数第二项。

 添加全局变量

添加一个。

 设置全局变量名字与初值

设置名字,和初值。

 生成的全局变量(名字前带 $)

就出现了一个全局变量,名字前带 “$”。

 引用全局变量

要引用时,只需要把名字添加进去,注意要带 “$”。

 带 $ 引用全局变量

一些技巧

围线成面

软件中默认给的平面绘制,能绘制的图形类型还是比较少的,有时候我们需要绘制特殊的图形,就需要自己画线,然后连成面了。

 三条线段围成三角形

在绘制直线的时候,只要线段最终形成一个封闭的面,软件会自动生成一个面。例如下面三条线段围成了三角形。

 软件自动生成面

软件自动生成了面。

直线变换

很多时候,要建立微带线,直接绘制长方体会比较繁琐,同时,绘制好的长方体无法改变尺寸。所以,我们一般直接使用直线工具来绘制。例如,现在绘制了一个20mm长的线段。

 绘制 20mm 长的线段

双击对应的叠层。

 双击叠层

修改它的类型,以及宽和高,点击确定。

 修改类型与宽高

这样,就生成了对应大小的一个长方体。

 生成的长方体

坐标定位

在绘制图形时,我们常常需要一个很精确的尺寸和坐标,此时,我们可以手动输入坐标值,而不是使用吸附功能。在绘制时,我们会发现,右下角的坐标轴随着鼠标的移动而变化。

 右下角坐标随鼠标变化

我们可以将鼠标移动到这里,然后手动输入下一个要绘制的点的坐标。选择Absolute,即绝对坐标,这个值是相对于原点(0,0,0)而言的,可以输入X,Y,Z。

 Absolute 绝对坐标

如果设置成Relative,则是相对坐标,这个值是相对于上一个点或参照点而言的,可以输入dX,dY,dZ。

 Relative 相对坐标

坐标变换

一般来说,我们绘制图形是以XY平面为底部的,网格也是在XY平面的,例如下面的图形。

 XY 平面网格示例

我们怎样切换网格显示的面,来达到不同的效果?首先设置坐标轴样式,这里改成YZ。

 坐标轴样式改为 YZ

可以看到,网格变到了YZ平面上。然后就可以在这个平面上绘图了。

 网格切换到 YZ 平面

绿油覆盖

有时候设计高速PCB时,需要考虑阻焊层,也就是俗称的绿油层,对电路的影响。由于铜层的线是凸起的,绿油覆盖上去也是凸起的,如何快速设计?

 基板与三条微带线

如图所示,我们绘制了一个基板,尺寸为20mm*20mm,在基板上绘制了三条微带线。当然,这个微带线的高度完全是不符合实际的,实际的铜层厚度一般为17um或者35um,这里为了效果更明显,设置了0.2mm的厚度。

 绘制覆盖基板的面

绘制一个面,只要比基板大,同时完全覆盖基板,移动至基板上方。

 选中所有

选中所有。

 Sheet 里选择 Project Sheet

在Sheet里选择Project Sheet。

 设置厚度 0.1mm

选择厚度和角度,这里设置厚度为0.1mm。按下确定。

 绿油覆盖上传输线

这个时候,绿油就覆盖上传输线了。

 绿油层属性设为 SolderMask

最后,别忘了把绿油层的物理化学属性设置成阻焊层。名称为SolderMask。

拉伸平面

在设计3D体的时候,往往无法一次设计到位,有时候需要对体的某一个面进行拉伸,来得到新的图形。

 选择捕捉设为 Face

首先设置选择捕捉为Face,也就是面。

 选中要拉伸的面(粉色)

选择要拉伸的面,会变成粉色。

 Surface 菜单第一项

在Surface里选择第一项。

 输入拉伸长度

在弹出的窗口中,输入要拉伸的长度。正数为轴的正方向,负数为轴的负方向。点击确定。

 拉伸后的图形

图形就被拉伸了对应的长度。

常用快捷键

按键 作用
鼠标中键 旋转窗口
Shift + 鼠标左键 移动窗口
Ctrl + D 显示所有图形

常见问题

图形显示不完整

 图形显示不完整示例

有时候,我们绘制了一个稍大的图形,但会发现,它显示不完整。当旋转图形的时候,显示的部分也会跟着变。

这可能是由于显卡驱动出错造成的,我们只需要去官网更新最新的WHQL驱动即可。更新完之后就显示正常了。

 更新驱动后显示正常

还有一种可能是,修改了图形之后显示不完全的,这时候需要把工程保存一下,然后关闭工程,再重新打开,就能正常显示了。

绘图后自动弹出参数窗口

 自动弹出参数窗口

在很多教程中会提到,绘制图形后自动弹出了参数窗口,方便直接对参数进行修改,特别是需要定义变量的时候,如下图。

 Tools -> Options -> General Options

在一些版本的软件中,这个是需要自己手动设置的。按照下图,选择“ Tools → Options → General Options… “。

 勾选 Edit properties of new primitives

选择 3D Modeler 中的Drawing,勾选 Edit properties of new primitives即可。

设置占用核心数量

第一次安装HFSS后跑仿真需要设置核心数量,才能完整利用上CPU的所有核心,提高仿真速度。

新版

 新版:点击 Analysis Config

新版软件的设置比较简单。点击”Analysis Config”。

 新版:核心数改为 6

软件提示我们,当前有6个CPU核心可以使用,我们在下面把数字改成6即可。

旧版

 旧版:Tools 里的 HPC 设置

旧版的设置隐藏得比较深。要先选择Tools里的HPC设置。

 选择 Edit

选择Edit。

 旧版:核心数改为 6

软件提示我们,当前有6个CPU核心可以使用,我们在下面把数字改成6即可。


来源:CSDN《HFSS(ANSYS Electronics)建立工程和基本绘图方法》
原文:https://blog.csdn.net/weixin_44115643/article/details/120475998
作者专栏:HFSS(ANSYS Electronics)专栏
整理录入:2026-10-23
打印/导出
QR Code
QR Code hfss建立工程和基本绘图方法 (generated for current page)